Uikit styles not loading

Hi, I moved my site from local to remote. On the remote site, the styling from my child theme is loading but the uikit styles are not. Any idea what could be the reason for this.

When I activate the beans parent theme the same is happening. When I load a standard wp theme there seems to be no problem.


compiler/uikit/2c30bf0.css?ver=4.5.2 was not found on this server.

How can I solve this?

Hey Bas, the first things that comes to my mind is that there could be a directory permission issue. Have you also tried to flush cache in Appearance->Settings?

If that doesn't work, please send me credentials via PM 🙂


Problem is solved.

It was indeed a permission issue. After the migration from my mamp server to the remote server the permission of the uploads and beans folder where set to 755. After changing permissions and flushing the cache the Uikit styles where loading.

Thanks Thierry for the help.


Hi, I just started creating my first custom child theme with beans. I have this same issue but with a site I moved to my local server from a live domain. I have run a url replacement in my database and even manually set my home and site url in my wp-config.php file.

My local host server attempts to load the uikit css and js files from the wp-content/uploads/beanscompiler/uikit/ folder but responds with a 404. Upon inspecting this foldes the numbered css and js files are not present. I changed permissions of the folder and all its subfolders to allow access but thse files are still not being created.

Is there a way to get beans to create those files or load the default uikit assets on my localhost server?

My child theme functions.php currently looks like this:


// Include Beans. Do not remove the line below.
require_once( get_template_directory() . '/lib/init.php' );

// Remove this action and callback function if you are not adding CSS in the style.css file.
add_action( 'wp_enqueue_scripts', 'beans_child_enqueue_assets' );

function beans_child_enqueue_assets() {
 wp_enqueue_style( 'child-style', get_stylesheet_directory_uri() . '/style.css' );


Write a reply

Login or register to write a reply, it's free!