Default layout problem

Hi, I have just discovered Beans on my journey to getting to grips with Wordpress and thought "great, this is really going to help!" But, sadly, I've fallen at the first hurdle. I can't change the default layout in any beans theme except by using the Force a Layout code snippet and from all the documentation at the basic level I assumed I could just click the one I wanted and it would change - "The default site layout is set via the “Default Layout” option in the Appearance->Customize admin tab". Am I missing something, should I be adding code or a template somewhere? Help please.

Hi Viv,

Nope you shouldn't have to change anything.

  1. So you tried to change the default layout in Appearance->Customize and it isn't taking effect on any pages right?
  2. Have you tried to disable your child theme and see if it happens with Beans Core enabled?
  3. Could you share a link to your site please?


Hi Thierry

Thanks for your reply.

  1. Correct.
  2. Beans Core has exactly the same result.
  3. I don't have a live site yet. I am using Instant Wordpress - - to enable me to work from my portable drive. I have been using it successfully for a while and all themes and plugins seem to work exactly as they should, no problems (unless due to inexperience!) so far apart from this one. The default layout thumbnails are visible on both edit pages and add new pages but when clicking "modify" and going to the customizer it is possible to select a different layout but the save button isn't live. I wondered if going direct to the customizer from appearance would have a different result but no, it still doesn't work. I have had a look at the background code but with my limited experience can't find anything obvious.

It would be sad if this won't work with Instant Wordpress as it is a really useful bit of software and I can see I would be using it to demonstrate to my future clients.



Hi Viv,

Beans layout isn't using anything special which could cause issues on your local install. That said, you are the only person who reported this issue and it is extremely difficult to debug without being able to reproduce it.

Could you perhaps do a quick video recording of the issue?


Just taking another look at this problem to see if I can solve it on my own - answer "no". Still using Beans theme, without a child theme and via the dashboard Appearance-customize, I have now removed all content from the sidebar to see if any page will revert to just content but no, I just get this message where the sidebar should be. "Sidebar Primary does not have any widget assigned!"

I know I can set page templates up for the individual pages that I want to use but as far as I can see from the documentation and any info found online e.g here - I should be able to choose my individual page layouts through the dashboard without any need for coding. There have been no replies to my previous post with screenshots of the problem so maybe it doesn't happen to anyone else or I am just too dim to work with Beans?

Write a reply

Login or register to write a reply, it's free!